





tp-link AC2100 Archer VR600 5.375 EGP Original price was: 5.375 EGP.4.575 EGPCurrent price is: 4.575 EGP.
tp-link AC1900 Dual Band Wi-Fi Router (Archer C80,4 Antennas) 4.950 EGP Original price was: 4.950 EGP.4.160 EGPCurrent price is: 4.160 EGP.
TPLink AC2100 Wireless MU-MIMO VDSL/ADSL Modem Router | VR2100
3.599 EGP Original price was: 3.599 EGP.3.560 EGPCurrent price is: 3.560 EGP.
| Brand | TP-Link |
| Frequency band class | Dual-Band |
| Wireless communication standard | 5 GHz Radio Frequency, 2.4 GHz Radio Frequency |
| Compatible devices | Laptop, Personal Computer, Tablet, Smart Television, Smartphone |
| Frequency | 5 GHz |
| Recommended uses for product | Home |
| Included components | Archer VR2100 |
| Connectivity technology | Wi-Fi, USB, Ethernet |
| Colour | Black |
| Antenna type | Fixed |
| Brand |
TP-link |
|---|---|
Warranty
|
2 Years |
Out of stock
Description
| Ports | 3 Gigabit LAN Ports, 1 Gigabit LAN/WAN Port, 1 RJ11 Port, 1 USB Port |
|---|---|
| Button | WPS Button, Reset Button, Power On/Off Button, Wi-Fi Button, LED On/Off Button |
| External Power Supply | 12V/1.5A |
| IEEE Standards | IEEE 802.3, IEEE 802.3u, 802.3ab |
| VDSL2 Standards | ITU G.993.2, Up to 35b profile (POTS) ITU-T G.993.5 (G.vector) ITU-T G.998.4 (G.INP) |
| ADSL Standards | Full-rate ANSI T1.413 Issue 2, ITU-T G.992.1(G.DMT), ITU-T G.992.2(G.Lite), |
| ADSL2 Standards | ITU-T G.992.3 (G.DMT.bis), |
| ADSL2+ Standards | ITU-T G.992.5 |
| Dimensions ( W x D x H ) | 8.5 × 6.5 × 1.4 in (216 × 164 × 36.8 mm) |
| Antenna Type | 3 External Dual Band Antennas + 1 Internal 5 GHz Antenna |
| WIRELESS FEATURES | |
|---|---|
| Wireless Standards | IEEE 802.11ac/n/a 5 GHz, IEEE 802.11b/g/n 2.4 GHz |
| Frequency | 2.4 GHz and 5 GHz |
| Signal Rate | 1733 Mbps on 5 GHz, 300Mbps on 2.4 GHz |
| Transmit Power | <20dBm (2.4 GHz), <23dBm (5 GHz) |
| Wireless Functions | Enable/Disable Wireless Radio, Wireless Statistics |
| Wireless Security | 64/128-bit WEP, WPA/WPA2, WPA-PSK/WPA-PSK2 encryptions |
| Wireless Schedule | Support 2.4 GHz and 5 GHz Wireless Schedule |
| SOFTWARE FEATURES | |
|---|---|
| Security | NAT Firewall, SPI Firewall, Access Control, Service Filtering, Denial of Service (DoS), SYN Flooding, Ping of Death, IP and MAC Address Binding |
| Operating Modes | VDSL/ADSL Modem Router, 3G/4G Router, Wireless Router |
| Management | Web-Based Configuration (HTTP / HTTPS ), Remote management, Command Line Interface, SSL for TR-069, SNMP v1/2c, Firmware Upgrade, Diagnostic Tools, Free Online Firmware Update |
| DHCP | Server, Client, DHCP Client List, Address Reservation, DHCP Relay |
| Port Forwarding | Virtual Server, Port Triggering, DMZ, ALG, UPnP |
| Dynamic DNS | DynDns, NO-IP, TP-Link |
| VPN | OpenVPN, PPTP VPN, IPSec VPN |
| Protocols | Supports IPv4 and IPv6 |
| ATM/PPP Protocols | ATM Forum UNI3.1/4.0, PPP over ATM (RFC 2364), PPP over Ethernet (RFC2516), IPoA (RFC1577/2225), MER\IPoE (RFC 1483 Routed), Bridge (RFC1483 Bridge), PVC – Up to 8 PVCs |
| Advanced Features | Parental Controls, Network Address Translation (NAT), Static Routing, RIP v1/v2 (optional), DNS Relay, DDNS, IGMP V1/V2/V3 |
| Guest Network | 2.4 GHz Guest Network, 5 GHz Guest Network |
| IPSec VPN | Supports up to 10 IPSec VPN tunnels |
| OTHERS | |
|---|---|
| Certification | CE, RCM, RoHS |
| Package Contents | DSL Modem Router External Splitter RJ11 DSL Cable RJ45 Ethernet Cable Power Adapter Quick Installation Guide |
| System Requirements | Microsoft Windows 98SE, NT, 2000, XP, Vista™ or Windows 7, 8, 8.1, 10, Mac OS, NetWare, UNIX or Linux Internet Explorer 11, Firefox 12.0, Chrome 20.0, Safari 4.0, or other Java-enabled browser Subscription with an internet service provider (for internet access) |
| Environment | Operating Temperature: 0℃~40℃ (32℉ ~104℉) Storage Temperature: -40℃~70℃ (-40℉ ~158℉) Operating Humidity: 10%~90% non-condensing Storage Humidity: 5%~90% non-condensing |
Reviews (0)
Be the first to review “TPLink AC2100 Wireless MU-MIMO VDSL/ADSL Modem Router | VR2100” Cancel reply
You must be logged in to post a review.
Related products
TP-LINK RE315 AC1200 Mesh Wi-Fi Range Extender
- Eliminate weak signal areas with whole home WiFi coverage.
- 2.4 GHz (300 Mbps) and 5 GHz (867 Mbps) dual-band WiFi connection ensures more stable wireless experience.†
- Creates a Mesh network by connecting to a TP-Link OneMesh™ router for seamless whole-home coverage.‡
- Adaptive Path Selection – connects to the fastest connection path to the router automatically and runs at top-speed.
- High Speed Mode – maximizes speed by using one WiFi band as dedicated backhaul, ideal for HD streaming and gaming.
- AP Mode – create a new Wi-Fi access point to enhance your wired network with Wi-Fi capability.
- Smart signal indicator helps to find the best location for optimal Wi-Fi coverage by showing the signal strength.
- Push the WPS button to easily connect to the router and you can uniformly manage from the Tether app or Web UI.
- Works with any Wi-Fi router or wireless access point.
TP-Link UB500 USB 5.0 Bluetooth Adapter for PC, 5.0 Bluetooth
- Bluetooth 5.0 – Applies the latest Bluetooth 5.0 technology, backward compatible with Bluetooth V4.0/3.0/2.1/2.0/1.1
- Wireless Connectivity – Provides stable and convenient communication between Bluetooth devices and your PC or laptop
- Nano-Sized – Ultra-small for convenient portability with reliable high performance
- Supported Operating System – Windows 11/10/8.1/7
TP-Link Archer C86 AC1900 Wireless MU-MIMO Wi-Fi Router
- 802.11ac Wave2 Wi-Fi —— 1300 Mbps on the 5 GHz band and 600 Mbps on the 2.4 GHz band.
- 3×3 MIMO Technology —— Transmitting and receiving data on three streams to pair flawlessly with your 3×3 clients.
- Boosted Wi-Fi Coverage —— Beamforming technology and six external antennas deliver a highly efficient wireless connection
- MU-MIMO —— To help your devices achieve optimal performance by making communication more efficient
- Personalized Management —— Advanced features like Parental Controls, Guest Network, and Access Control provide individualized tools for network management.
Deco X20-DSL AX1800 VDSL Whole Home Mesh WiFi 6 Router
8.950 EGP
- VDSL Modem Router + Mesh WiFi - Save a modem, and gaining a better WiFi experience
- Super VDSL2 Speed - Supports Profile 35b tech to deliver downstream up to 350 Mbps*
- Superior WiFi 6 speeds up to 1.8 Gbps - 1201 Mbps (5 GHz) and 574 Mbps (2.4 GHz) dual-band WiFi with WiFi 6 technology
- Fully Gigabit Ethernet - 4x Gigabit WAN/LAN Ethernet ports provide flexible internet access at warp speed**
- TP-Link HomeShield - Real-time IoT and network protection, robust Parental Controls, and comprehensive reports§
- True Seamless Roaming Mesh WiFi - Walk through your home and stay connected with the fastest possible speeds‡
TL-WN823N Mini Wireless N USB Adapter
300Mbps Mini Wireless N USB Adapter
- 300Mbps wireless speed ideal for smooth HD video, voice streaming and online gaming
- Mini-sized design for convenient portability with a reliable high performance
- SoftAP Mode – Turn a wired internet connection to a PC or Laptop into a Wi-Fi hotspot
- Easily setup a secure wireless connection with one-touch WPS button
TP-LINK TL-WR844N
300 Mbps Multi-Mode Access Point/ Wi-Fi Router
- High-Speed Wi-Fi - 300 Mbps wireless transmission rate is ideal for both bandwidth sensitive tasks and basic work.
- Boosted Coverage - Two omnidirectional antennas and 2×2 MIMO deliver strong Wi-Fi signal and reliable connections.
- Multi-Mode 4 in 1 - Supports Router, Access Point, Range Extender, and WISP modes to meet any network need.
- Parental Controls - Manages when and how connected devices can access the internet.
- Guest Network - Provides separate access for guests while securing the host network.
- Smooth HD Streaming - Supports IGMP Proxy/Snooping, Bridge and Tag VLAN to optimize IPTV streaming.
- IPv6 Supported - Compatible with the IPv6 (the latest Internet Protocol version 6).
Tapo C200 Pan/Tilt Home Security Wi-Fi Camera
| CAMERA | |
|---|---|
| Image Sensor | 1/2.9“ |
| Resolution | 1080p Full HD |
| Lens | F/NO: 2.4; Focal Length: 4mm |
| Night Vision | 850 nm IR LED up to 30 ft |
| View Range | 360° horizontal, 114° vertical |
| NETWORK | |
|---|---|
| Security | 128 bit AES encryption with SSL/TLS |
| Wireless Rate | 11Mbps(802.11b) 54Mbps(802.11g) 150Mbps(802.11n) |
| Frequency | 2.4 GHz |
| Wireless Security | WPA/WPA2-PSK |
| ACTIVITY NOTIFICATIONS | |
|---|---|
| Input Trigger | Motion detection |
| Output Notification | Push notification |
| VIDEO | |
|---|---|
| Video Compression | H.264 |
| Frame Rate | 15fps |
| Video Streaming | 1080p |
| SYSTEM | |
|---|---|
| Regulatory Certification | FCC, IC, CE, NCC |
| System Requirements | iOS 10+, Android 5.0+ |
| ENVIRONMENT | |
|---|---|
| Operating Temperature | 0°C~40°C (32°F~104°F) |
| Storage Temperature | -40°C~70°C (-40°F~158°F) |
| Operating Humidity | 10%~90%RH non-condensing |
| Storage Humidity | 5%~90%RH non-condensing |
| POWER | |
|---|---|
| Camera input | 3 Meter Power Cable |
| PACKAGE CONTENTS | |
|---|---|
| Package Contents | Tapo Pan/Tilt Home Security Wi-Fi Camera Power Adapter Quick Start Guide Mounting Screws Mounting Plate Camera Base |
| HARDWARE | |
|---|---|
| Button | Reset button |
| Indicator LED | System LED |
| Adapter Input | 100-240VAC, 50/60Hz, 0.3A |
| Adapter Output | 9.0V/0.6A |
| Dimensions (W x D x H) | 3.4 x 3.3 x 4.6 in. (86.6 x 85 x 117.7 mm) |
| AUDIO | |
|---|---|
| Audio Communication | 2-way audio |
| Audio Input & Output: | Built-in microphone and speaker |
AC750 Wi-Fi Range Extender Re 205
- Brings Wi-Fi dead zones to life with strong Wi-Fi expansion at a combined speed of up to 750Mbps*
- Operates over both 2.4GHz band(300Mbps) and 5GHz bands(433Mbps) for a more stable wireless experience
- Intelligent signal light helps to find the best location for optimal Wi-Fi coverage by showing the signal strength
- Works with any Wi-Fi router or wireless access point**
TP-Link Tapo C210 Pan Tilt Home Security WiFi Camera Crystal Clear 3MP TPLink
tp-link Deco M5 pack3 AC1300 Whole Home Mesh Wi-Fi System
TP-Link 300Mbps | TL-WA801N | Wireless N Access Point
| Brand Name | TP-Link |
| Wireless Communication Standard | 802.11b |
| Data Transfer Rate | 300 Megabits Per Second |
| Frequency Band Class | Single-Band |
| Special Features | Access Point Mode, LED Indicator |
| Connector Type | RJ45 |
| Color | White/Grey |
| Frequency | 2.4 Hz |
| Included Components | Quick installation guide, Power adapter. |
| Item Weight | 15.87 Ounces |
TP-Link AC1750 WiFi Extender (RE450), PCMag Editor’s Choice, Up to 1750Mbps, Dual Band WiFi Repeater
tp-link AC2100 Archer VR600
| Brand Name | TP Link |
| Special Features | Super vector |
| Frequency Band Class | Dual-Band |
| Wireless Communication Standard | 802.11n, 802.11b, 802.11ac, 802.11g |
| Compatible Devices | All |
| Frequency | 5 GHz |
| Recommended Uses For Product | Business,gaming,personal |
| Included Components | Router,power adapter, manual |
| Connectivity Technology | Wi-Fi |
| Color | black |
tp-link Archer | AC1200 C50 | Wireless Dual Band Router
1.745 EGP
- Upgrades powerful 802.11 ac Wi-Fi technology to experience smoother HD streaming and online gaming, delivering up to 1200 Mbps of Wi-Fi speed over dual 5 GHz (867 Mbps) and 2.4 GHz (300 Mbps) bands
- Four fixed external antennas provide stable wireless connections and optimal coverage; 4 10-100 Mbps LAN ports and 1 10-100 Mbps WAN port
- Guest network and parental control: Keeps your main network secure by creating a separate guest network for visitors; restricts the access time and contents for children devices with parental control
- Easy setup and management with Tether App, available on any Android and iOS device
- Make secure wireless connection quickly and easily with the push of a WPS button
TP-Link 5-Port 10/100Mbps Desktop Switch
375 EGP
TP-Link-WA850RE 300Mbps Wi-Fi Range Extender
- Range Extender mode boosts wireless signal to previously unreachable or hard-to-wire areas flawlessly
- Miniature size and wall-mounted design make it easy to deploy and move flexibly
- Easily expand wireless coverage at a push of Range Extender button
- Ethernet port allows the Extender to function as a wireless adapter to connect wired devices
- Tether App allows easy access and management using any mobile device
- LED Control function includes a Night Mode for peaceful sleep
TL-WN722N 150Mbps High Gain Wireless USB Adapter
TPLink |TL-WR840N 300Mbps Access Point/ Wireless N Router TL-WR840N (EU)
TL-WA1201 New AC1200 Wireless Access Point
2.250 EGP
- AC1200 Dual-Band Wi-Fi – 867 Mbps at 5 GHz and 300 Mbps at 2.4 GHz band.
- Flexible Deployment– Supports Passive PoE to carry electrical power and data simultaneously.
- Multiple Modes – Supports Access Point, Range Extender, Multi-SSID, and Client modes to meet any network needs.
- MU-MIMO Technology – Simultaneously transfers data to multiple devices for 2× faster performance.
- Boosted Coverage – Four fixed antennas equipped with Beamforming technology extend and concentrate the Wi-Fi signals.
- Captive Portal – Offers a designed portal page for heightened security and marketing.
TL-WR940N 450Mbps Access Point/ Wireless N Router
- 450Mbps wireless speed ideal for interruption sensitive applications like HD video streaming
- Three antennas increase the wireless robustness and stability
- Supports 3 modes: Router, Range Extender and Access Point modes
- Easy wireless security encryption at a push of WPS button
- Bandwidth Control: assigns your preferred devices with more bandwidth
TP-LINK 4G LTE Mobile Wi-Fi M7200
2.350 EGP
TP-LINK AC750 Wireless Dual Band Router Archer C24
TP-Link USB C To Ethernet Adapter(UE300C), RJ45 To USB C Type-C Gigabit Ethernet LAN Network Adapter
625 EGP
| Brand TP-Link |
| Hardware interface USB, Ethernet, USB 3.0 |
| Windows 11/10/8.1/8/7, Chrome OS, macOS, Linux (Ubuntu) for PCs, Macs, and Tablets |
| Compatible Devices: Laptop, Desktop Computer, Tablet |
| Item Dimensions LxWxH 7.1 x 2.5 x 1.6cm |
| Ethernet data link protocol, Gigabit Ethernet |
| Data transfer rate 1 gigabit per second |
| Item weight 0.04 pounds |








Reviews
There are no reviews yet.